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Agenda

Introduction

Formulas and functions

— Everyday functions

— Incorporated analyzes

— Diagrams
Processing data

— Sorting, filtrating and validating

— Datasources

— Pivot

— Graphic presentation (Pivot diagrams)
Presentation of the spreadsheet

— Conditioned formatting

— Page setup (for print etc.)

— Commenting and protecting the work sheet
Effective workflow

— Short on macros
Assignments and review

Extra (if there is time left)
— Goalseek
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Introduction

« Martin Leegard Poulsen
— Analytics Group, AU IT

— Study economics and business administration at
Aarhus University, Business and Social Sciences

e Contact:
— poul@asb.dk
— 24 87 51 87
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Introduction

* One large table of columns (A, B, C) and rows
(1, 2, 3) that forms cells (Al, B2, C3)

— Cell B3 is picked

[ I S I S I N6 B T

— Formula bar
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References

« Excel uses either relative or absolute references

— Relative references or used, if you want to use
numbers from cells that has a relative position to the
result cell

« =Al is a relative reference, and will move if you copy the
formula

A B Here: 4 up

| : EDI% and 1 left

1
2
3
4
2
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References

— Absolute references are used, if you would like to use
numbers from the same cell, no matter where the
result cell if places.

« =$A%1 is an absolute reference, and will always refer to A1

« =A%$1 will always refer to row 1, but the column will move
along

« =3$A1 will always refer to column A, but the row will move
along

Analytics Group
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Formulas and functions

« Formulas are written either directly into the cells

or in the formula bar:

sSUM

-

K v Jx

=D29+5UM(D30:D35)

- |

— Can contain mathematical expressions or integrated
functions as SUM

* Functions receive input, do a certain operation,

and make output in the same cell
— fxcontains a list of the functions

Analytics Group
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Overview of data

« EXxcel are constantly making a protocol with
common variabels

— Average, sum and guantity are constantly calculated
In the lower right corner:

Average: 4.5 Count: 4 Sum: 18

Use it to keep control of your data

Analytics Group
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Formulas and functions

The functions are alle described with input type
and operation

— Divided into categories

Insert Function I. ? is-l
Search for a function:
Type a brief description of what you want to do and then dick
Go
Or select a category: |Math & Trig IZI

Select a function:

wes _________________________________________[§
ACOS
ACOSH
AGGREGATE
ASIN
ASINH
ATAN

ABS(number)
Returns the absolute value of @ number, a number without its sign.

Help on this function

Ok ] ’ Cancel

See more at au.dk/it
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Everyday functions

e SUM(number1;number2;...)
— Sumproduct(table1;table2;...)

 ROUND(humber; decimals)

 COUNT (table)/ COUNTIF(table; condition)
— Counts the number of cells in af table (if condition is met)

« RAND()/RANDBETWEEN(smallest; largest)

— Generates a random number between 0 and 1 (or the
picked interval)

* IF(condition; ifTrue; ifFalse)
— Tests the condition and performs the operation
— Can also use AND()/OR() in the condition

Analytics Group
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Incorporated analyzes

* Add-Inns: File -> Options -> Add-Inns —>
Excel... ->Analysis ToolPak -> OK
— Data -> Data analysis

« Contains different pre-installed outputs:
— Descriptives
— Z-tests
— ANOVA (Varians analysis, both one and two sided)
— Correlation
— Etc.
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Incorporated analyzes, descriptives

-

H 1 J K M N 0
Descriptive Statistics
Input
Input Range: SCs4 SESH{
Grouped By: (@ Columns
©) Rows
Labels in first row
Output options
@ Output Range: 54517
() New Warksheet Ply:
() New Workbook
Summary statistics
Confidence Level for Mean: 95 g

A B C D E F G
1 The following data is well suited for the integrated analyses in excel:
2 Descriptives, correlation, ANOVA
3
4 iShop 1 Shop 2 Shop 3 K
5 E a9 40 25!
6 ! 25 28 305
7 E 9 18 21!
8 ! a6 12 22,
9 E 22 24 23!
10 ! az 5 15,
1 E a0 a0 30,
12 | 46 5 18:
13 : 33 30 36)
14 . I 25 49!
15
16
17 Shop 1 Shop 2 Shop 3
18
19 Mean 36,2 Mean 22,7 Mean 26,9
20 Standard Error 4,309679029 Standard Error 4,014003266 Standard Error 3,142716447
21 Median 41 Median 24,5 Median 24
22 Mode 46 Mode 40 Mode 30
23 Standard Deviation 13,62840172 Standard Deviation 12,69339286 Standard Deviation 9,938142013
24 Sample Variance 185,7333333 Sample Variance 161,1222222 Sample Variance 98,76666667
25 Kurtosis 0,005693546 Kurtosis -1,037729583 Kurtosis 1,789966422
26 Skewness -0,963898522 Skewness -0,102655616 Skewness 1,249103687
27 Range 41 Range 35 Range 34
28 Minimum 9 Minimum 5 Minimum 15
29 Maximum 50 Maximum 40 Maximum 43
30 sum 362 S5um 227 Sum 269
31 Count 10 Count 10 Count 10
32 Confidence Level(95,0%) 9,749171285 Confidence Level(35,0%) 9,08030624 Confidence Level(95,0%) 7,109318521
33

See more at au.dk/it

[ kth Largest:
[ kth Smallest:

1
1
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Incorporated analyzes, ANOVA

A B C D E F G H | il
The following data is well suited for the integrated analyses in excel:
Descriptives, correlation, ANCVA
ishopl Shop2  shop3 |
! 49 a0 3 : 2 y
: 25 28 30! Anova: Single Factor e
] ]
; 9 18 21 ik _
: a5 12 225 Input Range: Rz
1 (] (o |
! 22 24 23, Grouped By:
1 L] — ]
! 42 5 15: Help
: a0 40 30! Labels in first row
: a6 5 18, Alpha: 0,05
1 L]
! 33 30 36!
1 50 25 49: Output options
“““““““““““““““““ @ Output Range: SAS17 E
1 New Warksheet Ply:

Anova: Single Factor ~) New Workbook
SUMMARY \ -

Groups Count sum Average Variance
Shop 1 10 362 36,2 185,7333
Shop 2 10 227 22,7 161,1222
Shop 3 10 269 26,9 98,76667
ANOVA
Source of Variation 55 df MS F P-value F crit
Between Groups 954,60 2 4773 3,21326 0,055939 3,334131
Within Groups 4010,6 27 1485407
Total 4965,2 29

See more at au.dk/it
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Diagrams

« Diagrams can be inserted by the tab Insert ->
Diagrams:

— Now pick the diagramtype that is best representing the
data (can be changed later if it is necessary)

— It might be best to mark the data area first

Indsast Sidelayout Formler Data Gennemse  \ Vis

zde Multimedie- Figurer artart Skaermbillede Szfjle Streg  Cirkel Lig. Omrade Punktdiac

Klip - - . - sgjle~
Tllustratione 2D-sgjlediagram
v J= | Observation
B c Eﬂ‘ Bj‘ | E
ttige funktioner pa nedenstaende tal: 30-s6j Grupperet sojle
kt, afrund, teel, slump sammenlign veerdier pa tveers af
Jﬂ kategorier ved at bruge lodrette
Oprindelig veerdi  |Afrundet _‘-ﬁ rektangler.
1 3,86854429 Cylinde Bkk ges g=t gk t”J t-l rnes rgaek]f fctrlgle
2 48,8976921 elementer, f.eks. et histogram.
3 6,51353348 Jﬂjm T8O =0 [P
4 27,67933952

See more at au.dk/it
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Diagrams

 When the diagrams are created, you can use the
tabs design, layout and format to change almost
all aspects

— Design is used to change the data in the diagram:

-
Select Data Source | PR X
Chart data range: | EEiEAelEER- 03] |E|
| :‘_:ISﬂib\:h Row/Column |

Legend Entries (Series) Horizontal (Category) Axis Labels
| “3add || Edt | X Remove |« =] | =est |
1
b 2
3
4
| Hidden and Empty Cells OK. ] | Cancel

See more at au.dk/it
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Diagrams

« Layout is used to change the look of the diagram
— E.g. axis titles, labels, grid lines and more

I‘lﬁ‘ IIH‘ il | Wi

Chart Axis Legend Data Data Axes Gridlines Plot
Title = Titles = = Labels = Table v v Area =

‘ ‘ e I

Labels Axes Background

 Format is used to standard editing of objects (just as
In Word)

The diagram’s forces are in the many layout
possibilities. Explore them yourself ©
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Assignments

 Checklist

— Assignmentl — Count and slump: 45 — 50 participants

— Assignment 2 - IF-conditions: 7795,8 kr.
« Part 2: 6876,24 kr.

— Assignment 4 — ANOVA: Significant difference,
p-value = 0,00

Analytics Group
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Data processing are often easiest with data
tables:
— Insert -> Table -> Pick table

iy B C D
iB Last Name B First Name M Date of Birth [ sex B
2 Abercrombie 4| sorter med sidste forst ™
e Formulas are used on all rows: serr i mnecs ;
4 |Bagel | Sorter efter farv e - |.F
5 |Bahrami | _P-.-"I
6 Basalik ' ™
7 Berka M
2 Pradley . Datofiltre jM
- = = = 9 |Cabatana | [Seg (Alle) Plx] M
« Sorting is indicated by . oG | g "
11 Calinov | + 1978 .M
. 12 camelbeke ’.'" 977 M
L] | 1975 |
* The sorting can be by: bameon | 5% -
14 Campbell | + 1974 .M
15 Campbell | 7] 1973 M
— A-Z. 1-10, oldest-newst etc 16 Corpenter v
b} ) . ' -] 1971 '
17 |Carter | 1) 1870 i M
S t- I- t d = -I 18 Carvallo | S e \F
orting lists (days or similar) 15 caspar) e Y
20 Casqueiro | _M
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AARHUS
/v UNIVERSITET
BUSINESS AND

AL SCIENCES

Data processing, filtering

* Filter is indicated by -r
 Filtering can be by: A B : ;

E F
a

C d' - 5 |Schare 41 sort Smallest to Largest 22979 M 96000
- On ItlonS 6 |Reitzel il Sort Largest to Smallest 18033 F 32000"
7
8
9

Neipper Sort by Color g 21856 M 46000"

. Olafsson - 22039 M 42000

— Manual selection vt woom oo
10 Wolodzko 18188 M 100000"

11 Smith Number Filters > Equals... 65000

r

12 Kalyanaraman Search 0 Does Not Equal... 3000

13 [valle v (Select All} Greater Th "

14 Malcolmson e - sfeaterihan.. 1000"

n = n 15 |Eggerer Greater Than Or Equal To... 2000

e ItiIs pOSSIb|e to filter 16 sneathn
17 Keever Less Than Or Egual To... 3,0.0.0'

h 18 Dellamore Between.. 2000

r

y more than one 15 Jaie 000’
20 [Ting Above Average DDDD,

. 121 Song - 4000 -

Eelow Average )

Varl a e 22 |\Waxman 7000
23 cabatana [ ok ][ cancel Custom Filter.. —

24 Khosa 28506 M 5?000'

25 Samant Mandar 27713 23281 M 530-0-0'.

See more at au.dk/it
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Data processing, valldatlng

SA5 Soda PDF 2012

Data Review View Acrobat
] i ;I = [ e EET
AlZ ( e+ |->IEI :?'ﬂ?
FAE:Y =l g —

'he validating will be 27 . ¢
~u? Advanced | Columns Duplicates [Validation = Analysis =
Sort B Filter =i Data validation... L

on the chosen cells ~ .

— A drop down-list is c . | FIEi coorvedston cias
made by having a oata Vaitain =)
table with possible s [t [Eror ert
values as source

Any value

An error message will
tell if you have typed =

a wrong value
Apply these changes to all other cells with the same settings
Clear Al K ] l Cancel I
b

See more at au.dk/it
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Data processing, grouping

 Rows and columns
can be grouped so
they can easily be
hidden or shown

Ko
[ - | 2 Phillips Jeff M 36.000 Bogholder
- | 3 Ringgvist Joakim K 30.000 Bogholder
. - | 4 Ebdrup Mads I 98.000 Bogholder
Y D ff t f d t * | 5 Davidovski Velimir I 83.000 Bogholder
I e re n ro m a‘ a - | 6 Larsson Katarina M 55.000 Bogholder
- = - | 7 Basalik Evan i 93.000 Bogholder
fl Ite rl n g (h e re th e d ata - | 8 Rolecki Marek K 28.000 Bogholder
[=] 9 Malgorzaciak Janusz I 50.000 Bogholder

will still be in the
calculations)

Analytics Group
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" Data processing, pivottable

* Pivot tables are used to summarize data
— Gives overview of categories
— It is possible to go down in details
— You can make automatic graphs of the tables

 Insert -> PivotTable -> Mark data and output
location

Analytics Group



/v

AARHUS
UNIVERSITET

BUSINESS AND SOCIAL §C

Antal af Efternavn Kolonnenavne ~

Raekkenavne
-'Bogholderi
K
M
-/ Direktion
K
M
-'Marketing
K
M
-'Udvikling
K
M
Hovedtotal

* | Bogholder

22
69

91

Data processing, pivottable

Forsker Leder Sekreter Salger Hovedtotal

16
30

11

17

11

43

37
134

12

183

22

79

18

37
144

34

22
358

Analytics Group
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Data processing, pivotchart

160

140

120

100

80

60

40

20 -~

, i L

Bogholderi K Bogholderi Direktion K Direktion M Marketing K Marketing M Udvikling K Udvikling M
M

See more at au.dk/it .y
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Assignments

e Check list
— Assignment 7: Lowest row (Grandtotal)

Analytics Group
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Préééntation, conditional formatting

« Format (color, underline etc.) cells depending on

the content:

— Highlight cells that are larger than the average, equal
to 4 or the like

— Highlight top/bottom in series e.g. top 10 of the
largest or smallest values

— Make color scales eg. from red to yellow to green
* You can make more than one rule for the cells
E Hame Insert Page Layout Faormulas Data Review View Acrobat SAS Soda PDF 2012

Tl Cut . .| = )
& Calibri 11 v A A F == @~ =" Wrap Text Genera [ - EL._' |
53 Copy ~ =l —
Paste ) B 7 U~ i~ & A E = = | iE £85 [adMerge & Center ~ | &8~ o, » | %50 ;00 | Conditional | Format
# Format Painter — = . =¥ = = * | Formatting ~ fas Table ~
Clipboard Font Alignment MNuml

Analytics Group
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Presentation, page setup

* Find it in the tab "Page layout”
« Overview of page break -> Page break preview

A
4

« Better understanding of formulas by giving
names to cells or areas

— The tab Formulas -> Name manager 5 2o

lame
Manager B Create from Selection

Defined Names

Analytics Group
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Commenting

* Are often used to explain formulas or results
— Could also contain information e.g. on input data

— Very useful if several people should use the
worksheet or if you know you will forget what
something is

* You can add it by a right-click
— Alternatively use the tab Review -> new comment
— Right-click again to hide/show the comment

Analytics Group



/ AARHUS
N UNIVERSITET
BUSINESS AND SOCIAL SCIENC

Protection of sheets

* The sheet can be protected so it is only possible
to pick or edit specific cells :

— Is nice If there is a risk of someone changing the

formulas
* In home you can pick Format -> Lock cell
jig:;y' T N e e e E J [voma B [
Pagte'fg‘m,atpaimr BZUu- - & A EEE EI = ) ! Fomat | I ] y-. [mput ]

Then the tab Review -> Protect sheet
Make a password if you would like

Analytics Group
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Effectlve workflow, macros

« Make shortcut buttons for repeated processes
e.g. same format, formulas or the like

— Requires the tab Developer (File -> Options ->
Customize Ribbon -> Developer)

* Record macro
— Records alle clicks, inputs ect.
— Remember to stop the record again

Analytics Group
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‘Effective workflow, adjustment of
buttons

 Userdefined menues can be edited at File ->

Options -> Customize Ribbon :

— Submenues or whole tabs
— All commandoes + macros can be used

* You can use the toolbar "Quick Acces ” for very
common commandoes:

\

£2 |4

(] Ifid 9 -
Startside

Userdefined menu =

AMANVAL Billede

De gode funktioner

Min egen fane

Quick Acces

Userdefined tab

Analytics Group
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Goalseek

 |s used to see cause-effect on one variable
— Go to the tab Data -> What if -> Goal seek

A ___@___1 C D

Finds the number of units that 2 oee TR
gives a revenue of 1000 ' — e

fr Set cell: SB53 |£l

8 To value: 1000

3 ||| By changing cell: | ¢B31| & | |

10

11 [ Ok ] | Cancel | |

12 1%

 Can be expanded with the problem solver (not a
part of this course) to several variables and side
conditions

Analytics Group
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Assignments

 Checklist

— Extra assignment: conditional formatting: AVG. =
0,466

— Extra assignment: Goal seek: Rate = 6%

Analytics Group
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Questions

* If your question has not been answered here
you are welcome to contact us at:
— analytics@asb.dk
— au.dk/it (where you can also find this presentation)

Analytics Group
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This presentation is made by Analytics Group

ANALYTICS GROUP

Analytics Group, a division comprised of student instructors
under AU IT, primarily offers support to researchers and
employees.

Our field of competence is varied and covers questionnaire
surveys, analyzes and processing of collected data etc. AG
also offers teaching assistance in a number of analytical
resources such as SAS, SPSS and Excel by hosting courses
organised by our student assistants. These courses are often
an integrated part of the students’ learning process regarding
their specific academic area which ensures the coherence
between these courses and the students’ actual educational
requirements.

In this respect, AG represents the main support division in
matters of analytical software.

See more at au.dk/it

ADVANCED MULTIMEDIA GROUP

ADVANCED
MULTIMEDIA
GROUP

Advanced Multimedia Group is a division under AU IT
supported by student instructors. Our primary objective Is to
convey knowledge to relevant user groups through manuals,
courses and workshops.

Our course activities are mainly focused on MS Office, Adobe
CS and CMS. Furthermore we engage in e-learning activities
and auditive and visual communication of lectures and
classes. AMG handles video assignments based on the
recording, editing and distribution of lectures and we carry
out a varied range of ad hoc assignments requested by
employees.

In addition, AMG offers solutions regarding web development
and we support students’ and employees’ daily use of typo3.
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